Scanning FC/SAN LUNS in Solaris
Before scanning LUNS, we see some useful commands which are related to Fibre Channel(FC).
1.List the connected HBA’s.
root@Unixarena-SOL11:~# luxadm -e port |grep CONNECTED /devices/pci@1d,700000/SUNW,qlc@1,1/fp@0,0:devctl CONNECTED /devices/pci@1d,700000/SUNW,qlc@3/fp@0,0:devctl CONNECTED
2.Verify FC channel ‘s are connected and configured.
Unix@sol# cfgadm -al -o show_FCP_dev |grep fc-fabric c2 fc-fabric connected configured unknown c4 fc-fabric connected configured unknown Unix@sol#
3.To find the HBA’s World wide Node number (WWN),use fcinfo command,
Unix@sol# fcinfo hba-port |grep Port HBA Port WWN: 10000000c884bb48 HBA Port WWN: 10000000c884bb49 HBA Port WWN: 10000000c884b85c HBA Port WWN: 10000000c884b85d Unix@sol#
4.You can also find the WWN form luxadm command, if HBA is already connected to FC switch.
Unix@sol# luxadm -e dump_map /dev/cfg/c4 Pos Port_ID Hard_Addr Port WWN Node WWN Type 0 29900 0 50080e8008cfb814 50080e8008cfb814 0x0 (Disk device) 1 27400 0 10000000c884b85c 20000000c884b85c 0x1f (Unknown Type,Host Bus Adapter) Unix@sol#
From the above output, the last line shows the HBA information.In the same you can find the other controller information as well.
5.Zoning can be verified using the below command.
Unix@sol# cfgadm -al -o show_FCP_dev c2 c4
6.If you see any controller port “WWN” showing as “unconfigured” ,then you can initiate FC session using below mentioned command.
Unix@sol# cfgadm -c configure c2::50080e8008cfb814 Unix@sol# cfgadm -c configure c4::50080e8008cfb814
Let’s see how we can re-scan the SAN/FC luns on solaris 10/11 hosts.
To scan new FC luns, Just execute the below commands.
Scanning FC/SAN LUNS | ||
---|---|---|
1 | cfgadm -al | To scan FC luns |
2 | devfsadm -c disk | To make sure all the device files are created |
3 | tail /var/adm/messages | To see the new LUN’s information |
4 | echo |format | To get the new LUN’s information |
5 | ls -lrt /dev/rdsk |grep s2|tail | To get the new LUN’s information |
If you still not able to see the new LUNS/DISK ,then you can try to reset the HBA as last option if you have multipath enabled. (Do not try in critical servers unless you have confident on multipathing)
1.List the connected HBA.
root@Unixarena-SOL11:~# luxadm -e port |grep CONNECTED /devices/pci@1d,700000/SUNW,qlc@1,1/fp@0,0:devctl CONNECTED /devices/pci@1d,700000/SUNW,qlc@3/fp@0,0:devctl CONNECTED
2.Reset the HBA using forcelip option.
root@Unixarena-SOL11:~# luxadm -e forcelip /devices/pci@1d,700000/SUNW,qlc@1,1/fp@0,0:devctl
Forcelip can be issued to the controller names as well.
Unix@sol# cfgadm -al -o show_FCP_dev |grep fc-fabric c2 fc-fabric connected configured unknown c4 fc-fabric connected configured unknown Unix@sol# Unix@sol# luxadm -e forcelip /dev/cfg/c2
3. Verify the controller status using “cfgadm -al”.Make sure disks didn;t loose any SAN paths after the HBA reset. If everything seems to be okay ,then isssue the forcelip to the another controller.
If still you are not able to see the new FC/SAN LUNS ,then reboot the server and try. Once you see the new lun, make sure that multiple FC paths are enabled to that. Minimum two FC paths required for SAN disks.
” luxadm display /dev/rdsk/c1txxxxxxd0s2″ – To verify the FC lun details and multipathing.
Scanning Local SCSI disks in Solaris
1.List the currently available harddisks.
root@Unixarena-SOL11:~# echo |format Searching for disks...done AVAILABLE DISK SELECTIONS: 0. c8t0d0 /pci@0,0/pci15ad,1976@10/sd@0,0 1. c8t1d0 /pci@0,0/pci15ad,1976@10/sd@1,0 2. c8t2d0 /pci@0,0/pci15ad,1976@10/sd@2,0 3. c8t3d0 /pci@0,0/pci15ad,1976@10/sd@3,0 4. c8t4d0 /pci@0,0/pci15ad,1976@10/sd@4,0 5. c8t5d0 /pci@0,0/pci15ad,1976@10/sd@5,0 6. c8t6d0 /pci@0,0/pci15ad,1976@10/sd@6,0 Specify disk (enter its number): Specify disk (enter its number): root@Unixarena-SOL11:~#
2.Assume new SCSI harddisks are added to the server.
3.Scan the SCSI disks.
root@Unixarena-SOL11:~# devfsadm -c disk root@Unixarena-SOL11:~# echo |format Searching for disks...done AVAILABLE DISK SELECTIONS: 0. c8t0d0 /pci@0,0/pci15ad,1976@10/sd@0,0 1. c8t1d0 /pci@0,0/pci15ad,1976@10/sd@1,0 2. c8t2d0 /pci@0,0/pci15ad,1976@10/sd@2,0 3. c8t3d0 /pci@0,0/pci15ad,1976@10/sd@3,0 4. c8t4d0 /pci@0,0/pci15ad,1976@10/sd@4,0 5. c8t5d0 /pci@0,0/pci15ad,1976@10/sd@5,0 6. c8t6d0 /pci@0,0/pci15ad,1976@10/sd@6,0 7. c8t8d0 /pci@0,0/pci15ad,1976@10/sd@8,0 Specify disk (enter its number): Specify disk (enter its number): root@Unixarena-SOL11:~#
4.Still if you are not able to see the new disks,use cfgadm command and then devfsadm.
root@Unixarena-SOL11:~# cfgadm -al Ap_Id Type Receptacle Occupant Condition c8 scsi-bus connected configured unknown c8::dsk/c8t0d0 disk connected configured unknown c8::dsk/c8t1d0 disk connected configured unknown c8::dsk/c8t2d0 disk connected configured unknown c8::dsk/c8t3d0 disk connected configured unknown c8::dsk/c8t4d0 disk connected configured unknown c8::dsk/c8t5d0 disk connected configured unknown c8::dsk/c8t6d0 disk connected configured unknown c8::dsk/c8t8d0 disk connected configured unknown cfgadm: Configuration administration not supported: Error: hotplug service is pr ble the service. See cfgadm_shp(1M) for more details. root@Unixarena-SOL11:~# root@Unixarena-SOL11:~# devfsadm -c disk root@Unixarena-SOL11:~#
If you are using veritas volume manager, then you can verify the mutipathing using vxdmp commands.
Check out that article which provides the step by step method to SCAN FC luns on Redhat Linux.
Hope this post is informative for you .
Shitikantha says
What is the meaning of c with the command devfsadm
Raju says
Excellent Thanks
tushar says
very nice article.sharing the knowledge is sacred work
Basem says
Hi,
Thank you for the a great post.. How can identify the disks are multipathed disk ?
Thanks
Lingeswaran R says
If you are using VXVM, you can use vxdisk list lun_name to find the number of paths for the disk.
luxadm display /dev/rdsk/cxtxdxs2 also displays the number of FC paths on the system.
Muhammad Anwar says
Its very helpful. Thank you so much brother.
sudhakar says
cfgadm is there to manage LUNs in solaris, then why Luxadm is introduced? luxadm is by default available in solaris? please let me know
Muhammad Anwar says
@sudhakar
luxadm is available in Solaris by default. However cfgadm and luxadm do the same job but in different way. Some of us are easy with luxadm and some are with cfgadm.
Lamaison says
Thank you for sharing your knowledge.
Ved Prakash says
Valuable information